Resolved
This incident has been resolved.
Monitoring
A fix has been implemented and we are monitoring the results.
Identified
Our dashboard is experiencing degraded performance. Our team is currently working on resolving the issue to bring back the full functionality of the app.