Issue with subscription page (subprocessor issue)

Incident Report for ChatBot

Resolved

We identified an issue with one of our subprocessors, which caused issues with accessing subscription pages. The incident has been resolved on 10:00 AM CET.
Posted Feb 11, 2021 - 09:00 CET